<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>Oklahoma's March weather report</title><meta property=og:title content="OCS: Oklahoma's March weather report"/><link rel=amphtml href=https://amp.news-star.com/amp/7062895002 /><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.news-star.com /><link rel=preconnect href=https://user.news-star.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.news-star.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.news-star.com/NSNS-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z357c67ab5.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z3571b5191.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-eb1611d8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-454f9438.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-43a0b741.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-aa645eb8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-b3e4ce3e.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-c29e248c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-ac4c537c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="Oklahoma's March weather report"/><meta property=og:description content="Oklahoma's March weather report"/><meta property=fb:pages content=59594113415 /><meta property=fb:app_id content=269482051138438 /><link rel=canonical href=https://www.news-star.com/story/weather/2021/04/05/oklahomas-march-weather-report/7062895002/ /><meta property=og:url content=https://www.news-star.com/story/weather/2021/04/05/oklahomas-march-weather-report/7062895002/ /><meta property=og:site_name content="The Shawnee News-Star"/><meta property=og:image content="https://www.gannett-cdn.com/presto/2021/03/25/NSNS/0e488bf7-b019-4496-8f25-096a930d1eb6-_nice_light.JPG?crop=5999,3375,x0,y305&width=3200&height=1801&format=pjpg&auto=webp"/><meta property=og:image:width content=3200 /><meta property=og:image:height content=1801 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2021/03/25/NSNS/0e488bf7-b019-4496-8f25-096a930d1eb6-_nice_light.JPG?crop=5999,3375,x0,y305&width=1600&height=800&format=pjpg&auto=webp"/><meta name=twitter:site content=@shawneenewsstar /><meta name=twitter:creator content=@shawneenewsstar /><meta name=twitter:title content="OCS: Oklahoma's March weather report"/><meta name=twitter:description content="Oklahoma's March weather report"/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="The Shawnee News-Star" data-t-l=:n|v|c|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#303030 preserveAspectRatio="xMinYMid meet" viewBox="0 0 248.49 63.06"><path d="M20 5.93h-.38c-.35-1.41-2.08-4.58-3.46-4.78-.77-.1-1.8-.13-2.66-.13h-2.02v18.82c0 .71.26 1.28.99 1.6.38.16 2.05.48 2.63.51v.38H5.22v-.38c.58-.03 2.21-.19 2.63-.35.77-.29.99-.9.99-1.6V1.03H6.79c-.64 0-1.86.03-2.63.13C2.78 1.35 1.02 4.52.7 5.93H.28V.45H20v5.48zm25.42 16.42h-9.14v-.38c.58-.03 1.89-.13 2.31-.29.77-.29.99-.87.99-1.57v-8.85H27.72v8.69c0 .7.26 1.25.99 1.57.38.16 1.73.42 2.31.45v.38h-9.14v-.38c.58-.03 1.83-.13 2.24-.29.77-.29.99-.87.99-1.57V2.95c0-.7-.22-1.25-.99-1.57a9.27 9.27 0 00-2.24-.54V.45h9.14v.38c-.58.03-1.73.19-2.31.38-.8.26-.99.87-.99 1.57v7.76h11.86v-7.6c0-.7-.26-1.25-.99-1.57a9.7 9.7 0 00-2.31-.54V.45h9.14v.38c-.58.03-1.67.19-2.24.38-.8.26-.99.87-.99 1.57v17.15c0 .7.26 1.22.99 1.57.38.19 1.67.42 2.24.45v.4zm21.7-6l-.42 6H48.46v-.38c.58-.03 2.05-.16 2.53-.35.77-.29.99-.87.99-1.57V2.95c0-.7-.19-1.25-.99-1.57-.61-.26-1.96-.51-2.53-.54V.45h16.93v4.84h-.54c-.32-1.38-1.83-3.94-3.17-4.14-.77-.1-1.64-.13-2.66-.13H54.6v9.62h3.11c1.8 0 2.28-.67 2.66-1.06.48-.48.8-2.08.9-2.92h.55v8.82h-.55c-.06-.93-.51-2.66-.9-3.08-.42-.45-.93-1.06-2.66-1.06H54.6v7.41c0 2.63.61 2.92 3.85 2.92 2.28 0 4.94.1 5.71-.71.96-.99 2.18-3.65 2.5-4.62h.46zm23.98-.19a6.33 6.33 0 01-6.44 6.57 9.6 9.6 0 01-5.67-2.02l-1.09 1.96h-.54l-.22-7.31h.45c1.57 4.23 3.56 6.7 7.21 6.7 2.98 0 4.46-1.79 4.46-4.33 0-1.99-1.09-3.5-3.05-4.33-2.02-.87-2.63-1.09-4.71-2.05-2.37-1.09-3.69-2.63-3.69-5.58A5.45 5.45 0 0183.39.1a8.8 8.8 0 015.1 1.96L89.58.1h.54l.16 7.25h-.48C88.45 3.31 86.79.78 83.13.78c-2.31 0-3.72 1.54-3.72 3.37 0 2.02.8 3.11 2.66 4.1 1.7.9 2.85 1.25 4.42 2.02 2.81 1.34 4.61 2.49 4.61 5.89zm26.38 6.19h-9.14v-.38c.58-.03 1.89-.13 2.31-.29.77-.29.99-.87.99-1.57v-8.85H99.78v8.69c0 .7.26 1.25.99 1.57.38.16 1.73.42 2.31.45v.38h-9.14v-.38c.58-.03 1.83-.13 2.24-.29.77-.29.99-.87.99-1.57V2.95c0-.7-.22-1.25-.99-1.57a9.27 9.27 0 00-2.24-.54V.45h9.14v.38c-.58.03-1.73.19-2.31.38-.8.26-.99.87-.99 1.57v7.76h11.86v-7.6c0-.7-.26-1.25-.99-1.57a9.7 9.7 0 00-2.31-.54V.45h9.14v.38c-.58.03-1.67.19-2.24.38-.8.26-.99.87-.99 1.57v17.15c0 .7.26 1.22.99 1.57.38.19 1.67.42 2.24.45v.4zm24.1 0h-9.3v-.38c1.12-.06 3.37-.42 3.37-1.22 0-.22-.03-.54-.13-.77l-2.24-5.64h-8.08a43.63 43.63 0 00-1.51 4.1 7.19 7.19 0 00-.38 1.79c0 1.15 2.4 1.67 3.82 1.73v.38h-8.82v-.38a5.6 5.6 0 002.18-.61 5.14 5.14 0 002.05-2.5c2.28-5.48 5.13-12.66 7.53-18.75h.45c3.27 8.21 6.54 16.77 7.73 19.72.26.64.54 1.15 1.31 1.6.58.35 1.41.51 2.02.54v.39zm-8.56-8.69l-3.78-9.65-3.78 9.65h7.56zM169.95.84c-.61.03-1.51.26-2.08.61a3.69 3.69 0 00-1.63 2.02c-1.31 3.94-4.1 12.31-6.41 19.14h-.54a661.32 661.32 0 00-5.26-17.28L147.9 22.6h-.58c-2.5-8.4-4.91-16.8-5.71-19.68a2.29 2.29 0 00-1.15-1.54 4.91 4.91 0 00-2.08-.54V.45h9.2v.38c-1.12.06-3.49.42-3.49 1.19 0 .19.06.61.13.8.45 1.44 2.4 7.89 4.59 15.1l4.68-13.14c.06-.22.13-.51.13-.8 0-.87-.42-1.92-1.41-2.56a7.36 7.36 0 00-2.37-.58V.45h9.14v.38c-1.12.06-3.14.45-3.14 1.22 0 .22.06.58.13.8.42 1.35 2.47 7.66 4.75 14.91 1.73-5 3.17-9.36 3.91-11.96.51-1.76.67-2.4.67-3.24 0-1.12-2.28-1.63-3.75-1.73V.45h8.43v.39z"/><path d="M194.02.84c-.58 0-2.47.54-2.85.77-.93.55-1.12 2.28-1.12 4.26v16.77h-.8L174.53 4.01v12.53c0 2.44.45 3.81 1.15 4.39.54.45 2.85.99 3.43 1.03v.38h-9.36v-.38c.61-.06 2.5-.61 2.89-.83.74-.42 1.15-1.7 1.15-4.42v-12c0-1.12-.35-1.99-1.03-2.53A8.64 8.64 0 00169.2.8V.45h5.67l14.43 18.24V6.06c0-2.24-.38-3.88-1.09-4.3-.61-.38-2.63-.9-3.43-.93V.45h9.23v.39zm19.78 15.51l-.42 6h-18.24v-.38c.58-.03 2.05-.16 2.53-.35.77-.29.99-.87.99-1.57V2.95c0-.7-.19-1.25-.99-1.57-.61-.26-1.96-.51-2.53-.54V.45h16.93v4.84h-.54c-.32-1.38-1.83-3.94-3.17-4.14-.77-.1-1.63-.13-2.66-.13h-4.42v9.62h3.11c1.79 0 2.28-.67 2.66-1.06.48-.48.8-2.08.9-2.92h.54v8.82h-.54c-.06-.93-.51-2.66-.9-3.08-.42-.45-.93-1.06-2.66-1.06h-3.11v7.41c0 2.63.61 2.92 3.85 2.92 2.28 0 4.94.1 5.71-.71.96-.99 2.18-3.65 2.5-4.62h.46zm20.77 0l-.42 6h-18.24v-.38c.58-.03 2.05-.16 2.53-.35.77-.29.99-.87.99-1.57V2.95c0-.7-.19-1.25-.99-1.57-.61-.26-1.96-.51-2.53-.54V.45h16.93v4.84h-.54c-.32-1.38-1.83-3.94-3.17-4.14-.77-.1-1.63-.13-2.66-.13h-4.42v9.62h3.11c1.79 0 2.28-.67 2.66-1.06.48-.48.8-2.08.9-2.92h.54v8.82h-.54c-.06-.93-.51-2.66-.9-3.08-.42-.45-.93-1.06-2.66-1.06h-3.11v7.41c0 2.63.61 2.92 3.85 2.92 2.28 0 4.94.1 5.71-.71.96-.99 2.18-3.65 2.5-4.62h.46zM25.39 62.56L7.24 39.49v14.83c0 3.23.5 5 1.43 5.75.71.59 3.36 1.26 4.12 1.34v.92H.39v-.92c.71-.08 3.15-.63 3.86-1.13.97-.71 1.34-2.52 1.34-5.75v-14.7c0-1.26-.42-2.52-1.3-3.32-.97-.84-2.9-1.68-4.24-1.89v-.97H9.5l16.42 20.88V41.59c0-3.11-.5-5.04-1.43-5.71-.76-.55-3.28-1.22-4.12-1.3v-.92h12.35v.92c-.71.08-3.02.5-3.86 1.09-1.01.71-1.34 2.73-1.34 5.67v21.21h-2.13zm8.1-.21v-.92c.76-.08 2.69-.29 3.28-.55 1.01-.38 1.3-1.09 1.3-2.06V37.44c0-.92-.25-1.64-1.3-2.06-.8-.34-2.52-.71-3.28-.8v-.92h23.86v6.97h-1.13c-.5-1.89-2.73-5.29-4.71-5.59a27.35 27.35 0 00-3.44-.17h-4.41v11.97h3.15c2.31 0 3.07-.71 3.61-1.26.71-.71 1.3-2.81 1.43-3.91h1.13v11.8h-1.13c-.13-1.26-.84-3.49-1.43-4.12-.59-.63-1.39-1.26-3.61-1.26h-3.15v9.28c0 3.28.71 3.7 4.75 3.7 2.65 0 5.5.04 6.51-.97 1.47-1.47 3.11-4.83 3.61-6.17h1.05l-.55 8.4H33.49zm37.97.33c-2.52-8.15-7.02-22.26-7.9-25.16a3.45 3.45 0 00-1.6-2.14 6.42 6.42 0 00-2.69-.8v-.92h13.57v.92c-1.47.13-3.78.55-3.78 1.55 0 .25.08.8.17 1.09.42 1.47 3.4 10.88 5.71 17.94l5.5-15.04c-.25-1.72-.8-3.74-2.35-4.71a7.35 7.35 0 00-2.94-.84v-.92H89.1v.92c-1.47.13-3.99.55-3.99 1.55 0 .29.08.76.17 1.09.42 1.34 3.57 10.8 5.92 17.81a366.44 366.44 0 004.96-14.28c.63-2.06.88-3.19.88-3.91 0-1.47-2.73-2.1-4.66-2.27v-.92h11.3v.92c-.76.08-1.85.42-2.69.88-1.09.59-1.81 1.97-2.39 3.57-1.43 3.82-6.22 17.27-8.53 23.65H87.8a1356.5 1356.5 0 00-6.51-20.54l-7.52 20.54h-2.31zm42.63.25c-3.86 0-6.13-1.22-7.52-2.14l-1.39 1.93h-1.43l-.25-10.17h1.01c1.64 4.29 4.66 9.03 9.54 9.03 3.49 0 5.29-2.18 5.29-5.21 0-2.52-1.51-4.24-4.33-5.29-2.1-.8-3.82-1.39-5.71-2.18-3.4-1.47-5.04-4.12-5.04-7.77 0-4.5 3.57-8.11 9.03-8.11 2.6 0 5.17 1.01 6.64 2.02l1.26-1.81h1.47l.17 9.75h-.97c-1.89-5.25-4.37-8.61-8.74-8.61a4.25 4.25 0 00-4.28 4.45c0 2.52 1.39 3.99 4.07 5.21 1.97.88 3.95 1.47 5.59 2.18 3.44 1.51 5.67 3.4 5.67 7.86 0 5.13-4.16 8.86-10.08 8.86zm12.85-9.32V50h11.85v3.61h-11.85zm25.37 9.32c-3.86 0-6.13-1.22-7.52-2.14l-1.39 1.93h-1.43l-.25-10.17h1.01c1.64 4.29 4.66 9.03 9.54 9.03 3.49 0 5.29-2.18 5.29-5.21 0-2.52-1.51-4.24-4.33-5.29-2.1-.8-3.82-1.39-5.71-2.18-3.4-1.47-5.04-4.12-5.04-7.77 0-4.5 3.57-8.11 9.03-8.11 2.6 0 5.17 1.01 6.64 2.02l1.26-1.81h1.47l.17 9.75h-.97c-1.89-5.25-4.37-8.61-8.74-8.61a4.25 4.25 0 00-4.28 4.45c0 2.52 1.39 3.99 4.07 5.21 1.97.88 3.95 1.47 5.59 2.18 3.44 1.51 5.67 3.4 5.67 7.86 0 5.13-4.16 8.86-10.08 8.86zm17.13-.58v-.92c.76-.04 2.86-.34 3.4-.55 1.01-.38 1.3-1.18 1.3-2.1v-23.9h-1.47c-.97 0-2.27.04-3.23.17-1.81.25-4.07 4.28-4.58 6.13h-1.05v-7.52h26.25v7.52h-1.05c-.5-1.85-2.77-5.88-4.58-6.13-.97-.13-2.14-.17-3.23-.17h-1.47v23.69c0 .92.34 1.68 1.3 2.1.5.21 2.65.67 3.4.76v.92h-14.99zm26.59-10c-.84 2.31-1.47 3.99-1.55 4.33a8.4 8.4 0 00-.5 2.48c0 1.51 3.23 2.14 4.66 2.27v.92h-11.43v-.92a7.8 7.8 0 002.81-.8c1.05-.63 1.76-1.81 2.35-3.28 2.23-5.42 7.14-18.11 9.54-24.15h2.31c3.28 8.19 8.65 22.43 9.87 25.42.34.84.71 1.43 1.68 2.02.76.46 1.93.71 2.69.8v.92h-14.24v-.92c1.43-.13 4.16-.63 4.16-1.68 0-.29-.04-.63-.17-.92l-2.48-6.47h-9.7zm.55-1.51h8.57l-4.37-11.09c-1.35 3.48-2.94 7.73-4.2 11.09zm45.99 11.97c-3.53 0-5.29-2.02-5.92-7.01-.46-3.91-1.3-7.27-5.67-7.27h-2.44v10.25c0 .92.29 1.68 1.26 2.06.55.21 2.27.5 3.02.59v.92h-14.28v-.92c.76-.04 2.56-.29 3.11-.5 1.01-.38 1.3-1.13 1.3-2.1V37.35c0-.92-.25-1.72-1.3-2.1-.76-.29-2.35-.59-3.11-.67v-.92h15c5.29 0 9.83 1.93 9.83 6.51s-4.33 6.51-7.73 7.44v.34c2.06.25 5.38 1.3 6.22 4.37.63 2.31.84 4.12 1.34 6.13.42 1.64 1.3 1.97 2.02 1.97 1.05 0 1.97-1.22 1.97-3.82v-.88h1.18l-.04.92c-.17 3.69-1.56 6.17-5.76 6.17zm-14.03-15.54h1.72c3.7 0 6.85-1.47 6.85-6.3 0-4.58-2.56-6.09-5.92-6.09h-2.65v12.39z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class="gnt_n_sm_a gnt_n_sm__ne_a" data-u-sr="anon reg" href="https://subscribe.news-star.com/specialoffer?gps-source=CPTILELEFT&itm_campaign=2021SPRING&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (left nanobar)|p|c|${n}SUBSCRIBE NOW" elementtiming=nav-submsg></a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.news-star.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2021SPRING&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (right masthead)|p|c|SUBSCRIBE NOW" elementtiming=nav-submsg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=/news/ data-t-l=:n|v|c|news elementtiming=nav-item>News</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/sports/ data-t-l=:n|v|c|sports>Sports</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/entertainment/ data-t-l=:n|v|c|entertainment>Entertainment</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/lifestyle/ data-t-l=:n|v|c|lifestyle>Lifestyle</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/opinion/ data-t-l=:n|v|c|opinion>Opinion</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatoday.com/ data-t-l=:n|v|c|nation-world>USA TODAY</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/obituaries/ data-t-l=:n|v|c|obituaries>Obituaries</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://user.news-star.com/user/enewspaper data-t-l=:n|v|c|e-edition>E-Edition</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=http://oklahomanotices.com/ data-t-l=:n|v|c|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class="gnt_n_wt gnt_n_mn_ce" href=/weather/ target=_blank rel="external noopener" aria-label="Weather in Shawnee" title="Weather in Shawnee" data-t-l=:n|v|c|weather></a> <a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.news-star.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2021SPRING&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F" target=_blank rel=noopener data-t-l=:n|p|c|subscribe elementtiming=nav-subbt>Subscribe</a><div class=gnt_n_us_a_w data-g-r=nav_ce><a class="gnt_n_us_a gnt_n_mn_ce" href="https://login.news-star.com/NSNS-GUP/authenticate?success-url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F&cancel-url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F" data-g-r=nav_ab data-g-tn=navus data-t-l=":m|a|g|sign in / salutation" aria-label="Sign In" aria-haspopup=true aria-expanded=false><svg class=gnt_n_us_a_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></a></div></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-ok-shawnee-C6634-high_impact-weather-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=Weather data-c-ssts=WEATHER></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>OCS: Oklahoma's March weather report</h1><div class=gnt_ar_pb>Oklahoma Climatological Survey</div><div class=gnt_ar_dt aria-label="Published 10:38 a.m. CT Apr. 5, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.news-star.com/story/weather/2021/04/05/oklahomas-march-weather-report/7062895002/ data-ss-t="OCS: Oklahoma's March weather report" data-ss-d="Oklahoma's March weather report"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=269482051138438&href=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-top|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F&text=OCS%3A%20Oklahoma's%20March%20weather%20report&via=shawneenewsstar" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-top|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=OCS%3A%20Oklahoma's%20March%20weather%20report%20-%20from%20The%20Shawnee%20News-Star&body=OCS%3A%20Oklahoma's%20March%20weather%20report%0A%0AOklahoma's%20March%20weather%20report%0A%0ACheck%20out%20this%20story%20on%20news-star.com%3A%20https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F" data-t-l=${tc}|navbar-share-top|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-top|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><aside class="gnt_em gnt_em_vp__tavp gnt_em__el" aria-label="Video - 5 life-saving suggestions about hot cars"><div class="" data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-automatedvideoplayer><div class="gnt_em_vp_a gnt_em_vp__tavp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;ok-shawnee-C6634&#34;,&#34;pn&#34;:&#34;The Shawnee News-Star&#34;,&#34;vidNum&#34;:1,&#34;avp&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;news&#34;,&#34;byline&#34;:&#34;&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;USAT&#34;,&#34;createDate&#34;:&#34;2019-05-07T15:31:47Z&#34;,&#34;credit&#34;:&#34;USA TODAY&#34;,&#34;duration&#34;:73727,&#34;headline&#34;:&#34;5 life-saving reminders about hot cars&#34;,&#34;hlsURL&#34;:&#34;&#34;,&#34;id&#34;:&#34;1128233001&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2019/05/07/USAT/ba609980-1a73-499e-82f3-09c6159459ed-Screen_Shot_2019-05-07_at_10.48.51_AM.png&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2019-05-07T15:31:47Z&#34;,&#34;keywords&#34;:&#34;Hot car deaths,Video Syndication - USAT&#34;,&#34;mp4URL&#34;:&#34;https://mp4media.gannett-cdn.com/28911775001/28911775001_6033817909001_6033801023001.mp4&#34;,&#34;origin&#34;:&#34;USA TODAY&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/news/2019/05/07/5-life-saving-tips-hot-cars/1128233001/&#34;},&#34;promoBrief&#34;:&#34;Studies finds that hot cars can become deadly in as little as an hour for children and pets trapped inside.&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2019-05-07T15:31:47Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;news&#34;,&#34;subsection&#34;:&#34;&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;aec7164e-214a-4711-b93f-a4150fa3386b&#34;,&#34;name&#34;:&#34;Hot car deaths&#34;},{&#34;id&#34;:&#34;6f55135f-3b5e-490d-8a52-a3b8e1f11ee7&#34;,&#34;name&#34;:&#34;Video Syndication - USAT&#34;}],&#34;title&#34;:&#34;5 life-saving suggestions about hot cars&#34;,&#34;url&#34;:&#34;/videos/news/2019/05/07/5-life-saving-tips-hot-cars/1128233001/&#34;}"></div><button class=gnt_em_vp_db aria-label="Close autoplay video player" data-t-l=${tc}|tealplayer|automated-playerClose><svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2019/05/07/USAT/ba609980-1a73-499e-82f3-09c6159459ed-Screen_Shot_2019-05-07_at_10.48.51_AM.png?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="5 life-saving suggestions about hot cars" muted playsinline elementtiming=avp-video></video></div></div></aside><div class=gnt_ar_b><figure class="gnt_em gnt_em__fp gnt_em_img"><img class=gnt_em_img_i style=height:440px src="https://www.gannett-cdn.com/presto/2021/03/25/NSNS/0e488bf7-b019-4496-8f25-096a930d1eb6-_nice_light.JPG?width=660&height=440&fit=crop&format=pjpg&auto=webp" elementtiming=ar-lead-image srcset="https://www.gannett-cdn.com/presto/2021/03/25/NSNS/0e488bf7-b019-4496-8f25-096a930d1eb6-_nice_light.JPG?width=1320&height=880&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="After a rough bitter cold spell last month, Central Oklahoma begins its transition to Spring as birdsong fills the morning air."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="After a rough bitter cold spell last month, Central Oklahoma begins its transition to Spring as birdsong fills the morning air." data-c-credit="VICKY O. MISA SNS STAFF PHOTO"></div></figure><p class=gnt_ar_b_p>The first month of spring greeted Oklahoma with warmer and more tranquil weather than the historic cold and snowy February that preceded it.</p><p class=gnt_ar_b_p>While March offered up momentary glances of nearly every weather hazard in Oklahoma’s arsenal, the month was most often quiet. By coincidence—although state lore will say it’s the norm—the most active weather occurred during Oklahoma’s collectively shared spring break.</p><p class=gnt_ar_b_p>On March 16-17, local National Weather Service offices issued a blizzard warning in the Panhandle, and severe thunderstorm and tornado watches in the main body of the state. That storm system started with severe weather across western Oklahoma the evening of the 16th, and transitioned to snow the morning of the 17th. Snowfall of 3-4 inches was being driven by 40 mph winds to create white-out conditions across far northwestern Oklahoma throughout the day on the 17th while the severe weather was pushed east. The additional 3-4 inches of snow across the northwest brought seasonal totals to more than 40 inches in that region, with Arnett leading at 42.3 inches. Oklahoma City’s seasonal total of 22.5 inches through March was just 2.7 inches behind its record tally of 25.2 inches from 1947-1948, and ranked sixth highest on record. Tulsa’s seasonal total was 15.8 inches, its 17th highest on record and well behind 2010-2011’s 26.1 inches.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-ok-shawnee-C6634-native-article_link-weather-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>The statewide average precipitation total was 3.07 inches according to preliminary data from the Oklahoma Mesonet, 0.03 inches above normal, to rank as the 36th wettest March since records began in 1895. The northwestern half of the state saw surpluses of 1-3 inches, while the southeast fell 1-2 inches below normal. The moisture abundance was profound across parts of Oklahoma, with the Panhandle, north central and west central sections each experiencing one of their top 10 wettest Marches on record. The more robust totals came in Osage County, where Foraker and Burbank tallied 8.06 inches and 7.59 inches, respectively. Twenty-five of the 120 Oklahoma Mesonet sites recorded at least 4 inches of rain for the month. Thirty stations saw less than 2 inches, with Fort Cobb seeing the least at 0.64 inches. The first three months of the year ended as the 51st wettest since 1895 with a statewide average of 6.2 inches, 0.23 inches below normal. The January-March moisture distribution was similar to March’s pattern, with surpluses to the northwest and deficits to the southeast.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-ok-shawnee-C6634-native-article_link-weather-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>March was warm by any standard, but especially so following the historic cold weather of the previous month. The statewide average temperature for the month finished at 53.6 degrees, 3.2 degrees above normal, to rank as the 27th warmest March on record. High temperatures rose into the 70s and 80s quite often, with Beaver taking the top spot at 88 degrees on the 29th. Freezes were still common through the month, especially across far northwestern Oklahoma. Kenton recorded March’s lowest reading at 8 degrees on the month’s first day. The first three months of 2021 ended at 41.9 degrees, 1.6 degrees below normal and ranked as the 55th coolest January-March on record.</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>Drought continued to diminish in Oklahoma during March, dropping to an areal coverage of 10.71 percent on the month’s final U. S. Drought Monitor map. Drought was nearly eliminated across southwestern Oklahoma, although a newer area of drought was attempting to intensify and spread across south central Oklahoma. The April temperature and precipitation outlooks from the Climate Prediction Center (CPC) indicated increased odds of above normal temperatures across the entire state, and below normal precipitation across the western half of Oklahoma. Given those outlooks, CPC’s April drought outlook considered drought development likely in southwestern and west central Oklahoma, with no changes considered likely over the rest of the state.</p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.news-star.com/story/weather/2021/04/05/oklahomas-march-weather-report/7062895002/ data-ss-t="OCS: Oklahoma's March weather report" data-ss-d="Oklahoma's March weather report"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=269482051138438&href=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-bottom|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F&text=OCS%3A%20Oklahoma's%20March%20weather%20report&via=shawneenewsstar" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-bottom|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=OCS%3A%20Oklahoma's%20March%20weather%20report%20-%20from%20The%20Shawnee%20News-Star&body=OCS%3A%20Oklahoma's%20March%20weather%20report%0A%0AOklahoma's%20March%20weather%20report%0A%0ACheck%20out%20this%20story%20on%20news-star.com%3A%20https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F" data-t-l=${tc}|navbar-share-bottom|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-bottom|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-ok-shawnee-C6634-poster-weather-4 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=${tc}|rightRailTaboolaRecirc|click><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.news-star.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F&marketName=news-star&cta=Right-Rail" class=gnt_m_fs_a data-t-l=":survey|v|c|notice our new look..." aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-ok-shawnee-C6634-poster_scroll-weather-5 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/ data-t-l=|modalclose|x aria-label=Close></a></div></main></div><aside class=gnt_pm onmousedown=event.stopPropagation() onmouseup=event.stopPropagation() data-u-sr="anon reg" aria-label="free articles left. - Save on local news. $1 for 3 Months" data-g-r=base_ex><button class=gnt_pm_eb data-g-r=base_et aria-expanded=false aria-label="Special offer"></button><div class="gnt_pm_ms gnt_pm__de"></div><a class="gnt_pm_a gnt_pm__de" href="https://subscribe.news-star.com/?return-url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F&cancel-url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F&success-url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F&itm_medium=ONSITE&gps-source=CPCAMBARD&itm_source=CPCAMBARD&itm_content=freearticlesleft&itm_campaign=2021SPRING" aria-label="Subscribe Now" tabindex=0></a></aside><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-ok-shawnee-C6634-leaderboard_btf-weather-6 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="The Shawnee News-Star - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.news-star.com/accessibility/ class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility</a> <a href=https://www.news-star.com/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=http://oklahomanotices.com/ class=gnt_ft_a data-t-l=:f|v|c|about:legals>Legals</a> <a href=https://cm.news-star.com/ethical-conduct/ class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.news-star.com/terms/ class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.news-star.com/privacy/ class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.news-star.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.news-star.com/contact-us class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=:f|v|c|support:support-local-businesses>Support Local Businesses</a> <a href=https://localiq.com/markets/Oklahoma class=gnt_ft_a data-t-l=:f|v|c|support:advertise-your-business>Advertise Your Business</a> <a href=https://cm.news-star.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://adportal.marketplaceadsonline.com/gatehouse-adportal/oksha-classified/index.html? class=gnt_ft_a data-t-l=:f|v|c|support:buy-and-sell>Buy and Sell</a> <a href=https://imagn.com/licensing-reprints/ class=gnt_ft_a data-t-l=:f|v|c|support:licensing-and-reprints>Licensing & Reprints</a> <a href=https://help.news-star.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href=https://cm.news-star.com/subscriberguide class=gnt_ft_a data-t-l=:f|v|c|support:subscriber-guide>Subscriber Guide</a> <a href=https://account.news-star.com/ class=gnt_ft_a data-t-l=:f|v|c|support:my-account>My Account</a> <a href="https://cm.news-star.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F&marketName=news-star&cta=Footer" class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.news-star.com/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:subscribe-today>Subscribe Today</a> <a href=https://profile.news-star.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=https://www.facebook.com/ShawneeNewsStar/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href=https://twitter.com/shawneenewsstar/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:twitter>Twitter</a> <a href=https://user.news-star.com/user/enewspaper/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:e-edition>E-Edition</a> <a href=https://news-star.newsbank.com class=gnt_ft_a data-t-l=:f|v|c|stay-connected:archives>Archives</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=/jobs class=gnt_ft_a data-t-l=:f|v|c|our-partners:jobs>Jobs</a> <a href=/section/cars class=gnt_ft_a data-t-l=:f|v|c|our-partners:cars>Cars</a> <a href=/homes class=gnt_ft_a data-t-l=:f|v|c|our-partners:homes>Homes</a> <a href=http://www.marketplaceadsonline.com/marketplace/oksha class=gnt_ft_a data-t-l=:f|v|c|our-partners:classifieds>Classifieds</a> <a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:reviewed>Reviewed</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=:f|v|c|our-partners:reach-local>Reach Local</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.news-star.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3b18338f8.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z3571b5191.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><script type="gnt/tmpl" data-tmpl-key=navus><div class=gnt_n_us_dd data-g-r=nav_dd><div class=gnt_n_us_dd_u><a class=gnt_n_us_dd_a href=https://account.news-star.com/ data-t-l=":m|a|c|manage account">Manage Account</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://user.news-star.com/user/enewspaper data-t-l=:m|a|c|e-edition>E-Edition</a> <a class=gnt_n_us_dd_a href=https://profile.news-star.com/newsletters/manage/ data-t-l=:m|a|c|newsletters>Newsletters</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.news-star.com/pay data-t-l=":m|a|c|pay bill">Pay Bill</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.news-star.com/delivery-issue data-t-l=":m|a|c|report delivery issues">Report Delivery Issues</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://account.news-star.com/delivery-temporary-stop data-t-l=":m|a|c|pause delivery">Pause Delivery</a> <a class=gnt_n_us_dd_a data-u-sr="anon sub" href=https://cm.news-star.com/subscriberguide data-t-l=":m|a|c|subscriber guide">Subscriber Guide</a> <a class=gnt_n_us_dd_a href=https://help.news-star.com data-t-l=":m|a|c|help center">Help Center</a> <a class="gnt_n_us_dd_a gnt_n_us_dd_a__li" data-u-sr="reg sub" href="https://user.news-star.com/NSNS-GUP/user/logout/?return-url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F" data-t-l=":m|a|c|sign out">Sign Out</a></div><div class=gnt_n_us_dd_ac data-u-sr="anon reg"><div class=gnt_n_us_dd_lbl data-u-sr=anon>Have an existing account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_ba__hl" data-u-sr=anon rel=nofollow href="https://login.news-star.com/NSNS-GUP/authenticate?success-url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F&cancel-url=https%3A%2F%2Fwww.news-star.com%2Fstory%2Fweather%2F2021%2F04%2F05%2Foklahomas-march-weather-report%2F7062895002%2F" data-t-l=":m|a|c|sign in">Sign In</a><div class=gnt_n_us_dd_lbl>Already have a print subscription?</div><a class=gnt_n_us_dd_ba rel=nofollow href=https://cm.news-star.com/account-activation/ data-t-l=":m|a|c|activate account">Activate account</a><div class=gnt_n_us_dd_lbl data-u-sr=anon>Don't have an account?</div><a class="gnt_n_us_dd_ba gnt_n_us_dd_a__li" data-u-sr=anon rel=nofollow href="https://login.news-star.com/authenticate/?requested-state=create-account&amp;reg_source=CPNAVBAR&amp;reg_medium=ONSITE&amp;reg_campaign=signin&amp;reg_delivery=ux" data-t-l=":m|a|c|create account">Create account</a></div></div>|styles|.gnt_n_us_a_w{position:relative}.gnt_n_us_dd{display:none;position:absolute;top:28px;right:25px;padding:14px 0 14px 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_us_dd{display:flex}.gnt_n_us_dd_u{display:flex;flex-direction:column;min-width:165px;padding-right:15px}.gnt_n_us_dd_a{margin:3px auto 4px 3px;padding:0 2px;color:#fff;font:700 14px/18px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;white-space:nowrap}.gnt_n_us_dd_a:hover{color:#e0e0e0}.gnt_n_us_dd_ac{padding:0 15px 0 19px;border-left:1px solid #626262}.gnt_n_us_dd_lbl{margin:5px 0 0;color:#fff;font:700 12px/16px 'Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_us_dd_ba{display:block;width:192px;margin:3px 0 19px;padding:9px 1px 8px;border:3px solid #1665cf;outline-offset:-1px;color:#fff;font:700 14px/17px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif;text-decoration:none;text-align:center}.gnt_n_us_dd_ba__hl{padding:12px 4px 11px!important;border:0!important;background:var(--gnt-bc,#1665cf)}.gnt_n_us_dd_ba:hover{padding:8px 0 7px;border-width:4px;--gnt-bc:#0A32A0}.gnt_n_us_dd_a__li{margin-bottom:6px}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3LWXauP5k12MshXt+bgkWArz1fPI.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"OCS: Oklahoma's March weather report","description":"Oklahoma's March weather report","url":"https://www.news-star.com/story/weather/2021/04/05/oklahomas-march-weather-report/7062895002/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.news-star.com/story/weather/2021/04/05/oklahomas-march-weather-report/7062895002/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2021/03/25/NSNS/0e488bf7-b019-4496-8f25-096a930d1eb6-_nice_light.JPG?crop=4000,4000,x300,y0&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/03/25/NSNS/0e488bf7-b019-4496-8f25-096a930d1eb6-_nice_light.JPG?crop=5999,3375,x0,y305&width=1600&height=800&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-04-05T15:38:14Z","dateCreated":"2021-04-05T15:38:14Z","dateModified":"2021-04-05T15:38:14Z","articleSection":"weather","publisher":{"@type":"Organization","name":"The Shawnee News-Star","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/news-star/images/site-nav-logo@2x.png"}},"author":"Oklahoma Climatological Survey","keywords":["access:metered","ssts:weather","type:story","tag:Weather","tag:Weather","tag:Overall Neutral","tag:weather","tag:Temperatures","tag:Thunderstorms","tag:National Weather Service","tag:Spring break","tag:Oklahoma"],"isAccessibleForFree":false,"isPartOf":{"@type":["CreativeWork","Product"],"name":"Oklahoma Climatological Survey - Unlimited Digital Access","productID":"news-star.com:standard"},"metadata":"{\"id\":\"7062895002\",\"siteCode\":\"NSNS\",\"contentSourceCode\":\"NSNS\",\"ssts\":\"weather\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/03/25/NSNS/0e488bf7-b019-4496-8f25-096a930d1eb6-_nice_light.JPG","caption":"After a rough bitter cold spell last month, Central Oklahoma begins its transition to Spring as birdsong fills the morning air.","copyrightHolder":"VICKY O. MISA SNS STAFF PHOTO"}]</script></body></html>